<< Previous Page WP EasyCart Documentation Next Page >>

System Requirements

This page describes what server requirements or any other special software requirements are needed to install the WP EasyCart software.

PHP

Note: We have tested our software on PHP 5.3, PHP 5.4, and PHP 5.5 but there are hundreds of configurations available on hosts that can cause any number of issues with all shopping platforms. We recommend testing.

The latest available PHP 5.4 is recommended.

PHP Settings

  • Session Path must be set on your server
  • Upload_Max_filesize: 25M or greater for images and uploads
  • post_max_size: 25M or greater for images and uploads
  • max_file_uploads: 20
  • max_execution_time: 600
  • max_input_time: 600

MySQL

MySQL version 5.0 or later (We recommend the most current stable release)

Web Server

Most hosting environment web servers are capable of running the EasyCart plugin. Apache and IIS being the most popular, and every configuration being different, most of the configuration requirements fall within the PHP settings.


Recommended Hosted Environments

We have tested our system on many hosting environments but have best luck installing and configuring our plugin hosted on BlueHost. The default shared hosting plans tend to be configured completely and have the least issues regarding PHP setting changes, with default configurations working almost all the time.

Note: Other hosting environments with the proper version of PHP and WordPress installed are most likely going to work. If you have a server that is not compatible, often a hosting company will make the recommended changes for you if you ask.